Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 10 days ago. Mar 22, 2025 - 11:00 AEDT
Scheduled
Our Parsing Partner is undergoing scheduled maintenance. During this period, job applications will continue to be processed successfully, however, parsing of resumes will be delayed until their maintenance has been completed.
Posted 14 days ago. Mar 18, 2025 - 16:09 AEDT
This scheduled maintenance affected: Recruit Wizard.