Support Phone Number Unavailable
Incident Report for Recruit Wizard
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 11:45 AEST
Investigating
Our VOIP provider currently has an outage which means that calls are not getting through to us. If you need to chat, please log a ticket with us ( support@recruitwizard.com )
Posted Jun 15, 2021 - 10:45 AEST
This incident affected: Support Team.