Support Phone Number Unavailable
Incident Report for Recruit Wizard
Resolved
We have migrated to a new Supplier and happy to announce our new phone system is online.
Posted Mar 31, 2021 - 12:49 AEDT
Investigating
Our VOIP provider currently has an outage which means that inbound calls are not getting through to us. If you need to chat, please log a ticket with us ( support@recruitwizard.com ) and we will call you back ASAP
Posted Mar 26, 2021 - 10:29 AEDT
This incident affected: Support Team.