Recruit Wizard Signing not sending contracts for signing
Incident Report for Recruit Wizard
Resolved
This incident has been resolved.
Posted May 19, 2022 - 17:13 AEST
Identified
We have identified an issue with our 3rd party partner which is preventing the sending of documents for esigning. We have reported it to them and are awaiting an update.
Posted May 19, 2022 - 16:45 AEST
This incident affected: Recruit Wizard Sign (Electronic Signing).