Recruit Wizard - Recruit Wizard Signing not sending contracts for signing – Incident details

All systems operational

Recruit Wizard Signing not sending contracts for signing

Resolved
Major outage
Started about 3 years agoLasted 28 minutes

Affected

Communications

Operational from 6:45 AM to 6:45 AM, Major outage from 6:45 AM to 7:13 AM

Electronic Signing

Operational from 6:45 AM to 6:45 AM, Major outage from 6:45 AM to 7:13 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    We have identified an issue with our 3rd party partner which is preventing the sending of documents for esigning. We have reported it to them and are awaiting an update.