Delays in sending emails from Recruit Wizard
Resolved
Jul 29, 2026 at 10:26am UTC
We have restored email functionality across the platform and succesfully sent anything that was queued (Or that had errored).
If you believe there is an email that hasn't send, please reach out to support@recruitwizard.com who can investigate
Affected services
Updated
Jul 29, 2026 at 9:11am UTC
We have been able to release the majority of delayed emails are are continuing to work with our Emailing Partner on a full fix.
Affected services
Updated
Jul 29, 2026 at 7:58am UTC
We have identified the root cause of this issue and are working with our email partner to resolve this.
Affected services
Created
Jul 29, 2026 at 7:26am UTC
We are currently investigating delays in emails being sent by Recruit Wizard
Affected services