Moving Recruit Wizard to https://recruitwizard.app
Scheduled for November 22, 2025 at 1:00 AM – 1:32 AM
Affects
Recruit Wizard
Under maintenance from 1:00 AM to 1:32 AM
Completed
November 22, 2025 at 1:32 AMCompleted
November 22, 2025 at 1:32 AMMaintenance has completed successfully.
If you run into any issues signing in, please clear your cookies and cache.
In progress
November 22, 2025 at 1:00 AMIn progress
November 22, 2025 at 1:00 AMMaintenance is now in progress
Planned
November 22, 2025 at 1:00 AMPlanned
November 22, 2025 at 1:00 AMAs announced via email we are moving recruit wizard to be hosted at https://recruitwizard.app.
This change is part of our ongoing work towards achieving ISO 27001 certification, strengthening our commitment to security and reliability.
We expect recruitwizard to be unavailable for roughly 15 minutes during this window.