Recruit Wizard - Intermittent email deliverability issues affecting Microsoft emails (Outlook, Hotmail) – Incident details

All systems operational

Intermittent email deliverability issues affecting Microsoft emails (Outlook, Hotmail)

Resolved
Degraded performance
Started about 1 month agoLasted 1 day

Affected

Communications

Degraded performance from 10:00 PM to 12:45 AM

Email Sending

Degraded performance from 10:00 PM to 12:45 AM

Updates
  • Resolved
    Resolved

    Our email deliverability partner has addressed this issue, and after a period of monitoring the results we can confirm that deliverability of messaging to Microsoft domains such as Hotmail and Outlook is now operating normally.

  • Identified
    Identified

    Our email deliverability partner has identified an issue intermittently affecting email deliverability to Microsoft domains such as Hotmail and Outlook. This does not impact emails delivered to Microsoft 365 emails.

    Their engineering and deliverability teams are actively working towards a resolution.