Recruit Wizard - Support Phone Number Unavailable – Incident details
All systems operational
Support Phone Number Unavailable
Resolved
Degraded performance
Started over 4 years agoLasted 5 days
Affected
Support Team
Operational from 11:29 PM to 11:29 PM, Degraded performance from 11:29 PM to 1:49 AM
Updates
Resolved
Resolved
We have migrated to a new Supplier and happy to announce our new phone system is online.
Investigating
Investigating
Our VOIP provider currently has an outage which means that inbound calls are not getting through to us. If you need to chat, please log a ticket with us ( support@recruitwizard.com ) and we will call you back ASAP