Recruit Wizard - Support Phone Number Unavailable – Incident details

All systems operational

Support Phone Number Unavailable

Resolved
Degraded performance
Started over 4 years agoLasted about 1 hour

Affected

Support Team

Operational from 12:45 AM to 12:45 AM, Degraded performance from 12:45 AM to 1:45 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Our VOIP provider currently has an outage which means that calls are not getting through to us. If you need to chat, please log a ticket with us ( support@recruitwizard.com )