Scheduled for March 22, 2025 at 12:00 AM – 1:00 AM
Affects
Recruit Wizard
Under maintenance from 12:00 AM to 1:00 AM
Completed
March 22, 2025 at 1:00 AMCompleted
March 22, 2025 at 1:00 AMThe scheduled maintenance has been completed.
In progress
March 22, 2025 at 12:00 AMIn progress
March 22, 2025 at 12:00 AMScheduled maintenance is currently in progress. We will provide updates as necessary.
Update
March 21, 2025 at 11:00 PMPlanned
March 21, 2025 at 11:00 PMMaintenance will begin as scheduled in 60 minutes.
Planned
March 18, 2025 at 5:09 AMPlanned
March 18, 2025 at 5:09 AMOur Parsing Partner is undergoing scheduled maintenance. During this period, job applications will continue to be processed successfully, however, parsing of resumes will be delayed until their maintenance has been completed.